Weekly maintenance
Incident Report for Matrix Requirements
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 07, 2018 - 03:34 CEST
Investigating
Every Saturday, some time between 3am and 8am (CET time), we perform a server maintenance. There is normally no disruption to our services.
Posted about 1 year ago. Jul 07, 2018 - 03:19 CEST