Emails sent through Matrix not working anymore
Incident Report for Matrix Requirements
Resolved
We are still working with Microsoft and Mailgun, for now all is working fine.
Posted 11 months ago. Dec 04, 2018 - 16:03 CET
Update
Still working with Microsoft to ensure it doesn't happen anymore
Posted 11 months ago. Dec 04, 2018 - 15:16 CET
Monitoring
Mailgun added another IP address - that should overcome the issue. We are still monitoring the issue
Posted 11 months ago. Dec 04, 2018 - 08:47 CET
Identified
Microsoft Office365 apparently decided that we were sending too many emails so put our mail provider (Mailgun) on a blacklist. They will not be able to fix the issue before tomorrow (Dec 4th) in Europe business time.

The issue affects only our customers that have their emails handled by Office365.

Sorry for the inconvenience
Posted 11 months ago. Dec 03, 2018 - 18:31 CET
Update
We are still investigating this issue with Microsoft
Posted 11 months ago. Dec 03, 2018 - 18:03 CET
Investigating
Our email provider has some issues sending the emails sent from inside Matrix
Posted 11 months ago. Dec 03, 2018 - 15:00 CET
This incident affected: Emails.