Matrix Support Channels

Incident Report for Matrix Requirements

Resolved

We've been monitoring the issue over the past three hours and can confirm that the issue is officially resolved.
Posted Nov 19, 2025 - 22:06 CET

Monitoring

Our service desk provider let us know that they have implemented a fix and are monitoring for recovery. We will let you know when we are fully confident in their recovery
Posted Nov 19, 2025 - 19:06 CET

Investigating

Our service desk provider is currently experiencing an outage, which means the support widget is temporarily unavailable. In the meantime, you can continue to reach us via email at support@matrixreq.com, as usual. We’re actively monitoring the inbox and will respond as normal.
Posted Nov 19, 2025 - 17:50 CET
This incident affected: Matrix Support Channels.